Bug 41 - tracejob creates a file in the local directory
: tracejob creates a file in the local directory
Status: RESOLVED FIXED
Product: TORQUE
clients
: 2.3.x
: PC Linux
: P5 normal
Assigned To: Al Taufer
:
:
:
  Show dependency treegraph
 
Reported: 2009-12-09 11:29 MST by Craig West
Modified: 2009-12-09 15:52 MST (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Craig West 2009-12-09 11:29:31 MST
When running tracejob I find a file gets created or overwritten in the local
directory. The filename is "1".

It appears to be associated with looking for multiple files in the sched or mom
log areas.

The contents of the file from a tracejob <jobid> are:
  ls: cannot access /var/spool/torque/sched_logs/20091209.*: No such file or
directory

If I run the same command with the "-l" flag (no scheduler logs), I get:
  ls: cannot access /var/spool/torque/mom_logs/20091209.*: No such file or
directory

If a file already exists in this directory called "1" then it gets overwritten.

There was no problem in 2.3.7
I am running torque-2.3.8-snap.200912070305
The torque-2.4.3-snap.200912070303 version probably has the same problem.

I suspect the problem is on line 835 of tracejob.c
Comment 1 Al Taufer 2009-12-09 15:52:37 MST
Fix checked into 2.3, 2.4 and 2.5 branches.